Fedora 10 now work natively with eeepc

Use
/dev/sda1 – 100m for /boot
/dev/sda2 – 3700m for /
/dev/sda3 – rest for swap
/dev/sdb1 – all for /usr

Webcam work by changing /Sys/devices/platforms/eeepc/camera to 1
Wifi works perfectly
Wired network works perfectly
Skype works mean mic, speaker & webcam ok
Vlc works fine
Install vmware server 2.0

EeePC running on vmware

The instruction provided in sourceforge how to setup the EeePC with vmware need one last step. The xorg.conf cannot display the xwindow properly.

I use another vmware instance like CentOS to mount the vmware disk of the EeePC installed. Copy the below and detach the EeePC’s vmware disk and it works though the vmware network card not support by Xandos’s based EeePC OS. Lack of interests to fix it. May be later.

Thank you posting in http://forum.eeeuser.com/viewtopic.php?pid=200740#p200740 which provide the below.

Section “ServerLayout”
Identifier “Xandros”
Screen 0 “Screen1”
InputDevice “keyboard”
InputDevice “mouse”
EndSection

Section “Files”
ModulePath “/usr/lib/xorg/modules”
FontPath “/usr/share/fonts/X11/misc”
FontPath “/usr/share/fonts/X11/Type1”
FontPath “/usr/share/fonts/X11/75dpi”
FontPath “/usr/X11R6/lib/X11/fonts/Type1”
EndSection

Section “ServerFlags”
Option “AllowMouseOpenFail”
Option “BlankTime” “5”
Option “DontVTSwitch” “true”
Option “AIGLX” “false”
Option “GLX” “false”
Option “GLCore” “false”
EndSection

Section “InputDevice”
Identifier “keyboard”
Driver “kbd”
Option “CoreKeyboard”
Option “XkbRules” “xorg”
Option “XkbLayout” “us”
Option “XkbVariant” “”
EndSection

Section “InputDevice”
Identifier “mouse”
Driver “mouse”
Option “Device” “/dev/input/mice”
Option “Protocol” “IMPS/2”
Option “Emulate3Buttons” “yes”
Option “ZAxisMapping” “4 5”
Option “CorePointer”
EndSection

Section “Monitor”
Identifier “Monitor1”
VendorName “ASUS”
ModelName “eeePC P701”
Modeline “800×480” 29.58 800 816 896 992 480 481 484 497 -HSync +Vsync # 60 Hz
EndSection

Section “Device”
Identifier “Device1”
Driver “vesa”
EndSection

Section “Screen”
Identifier “Screen1”
Device “Device1”
Monitor “Monitor1”
DefaultDepth 24
SubSection “Display”
Depth 8
Virtual 1680 1680
EndSubSection
SubSection “Display”
Depth 15
Virtual 1680 1680
EndSubSection
SubSection “Display”
Depth 15
Virtual 1680 1680
EndSubSection
SubSection “Display”
Depth 16
Virtual 1680 1680
EndSubSection
SubSection “Display”
Depth 24
Virtual 800 600
EndSubSection
EndSection

eeepc 900 now install with fedora 9 using SDHC card inserted in the builtin reader

change the BIOS setting to boot from card reader.
connect external DVD reader with DVD burned with Fedora 9 i386 image
select the atl2 network driver
deselect the internal SSD harddisks and let Fedora 9 install only to the SD card
after 1+ hour install. It boots successfully
The built in wired connection work so I can connect to internet and post this message.
Change the display to 1024×768 under the menu (System/Display)
logout and login again then change the resolution to 1024×600 using System/Preference/Hardware/Screen Resolution

Problems noted:

Battery life checking not work quite well
Wireless lan not configured after first boot – This is now solved by yum –enablerepo=livna-testing install kmod-madwifi. ¬†Thanks¬†http://kernelreloaded.blog385.com/index.php/archives/madwifi-wireless-for-asus-eee-pc-on-fedora-9-howto/
….

Next steps:

updating new packages and refresh the systems
Finding way to enable wireless
Need to check if the built in web cam work – it works nows but can I disable in BIOS but still work? Default BIOS setup is to disable WebCam

Another nice documents http://fedoraproject.org/wiki/EeePc#ACPI_State_of_play