EeePC running on vmware

The instruction provided in sourceforge how to setup the EeePC with vmware need one last step. The xorg.conf cannot display the xwindow properly.

I use another vmware instance like CentOS to mount the vmware disk of the EeePC installed. Copy the below and detach the EeePC’s vmware disk and it works though the vmware network card not support by Xandos’s based EeePC OS. Lack of interests to fix it. May be later.

Thank you posting in http://forum.eeeuser.com/viewtopic.php?pid=200740#p200740 which provide the below.

Section “ServerLayout”
Identifier “Xandros”
Screen 0 “Screen1”
InputDevice “keyboard”
InputDevice “mouse”
EndSection

Section “Files”
ModulePath “/usr/lib/xorg/modules”
FontPath “/usr/share/fonts/X11/misc”
FontPath “/usr/share/fonts/X11/Type1”
FontPath “/usr/share/fonts/X11/75dpi”
FontPath “/usr/X11R6/lib/X11/fonts/Type1”
EndSection

Section “ServerFlags”
Option “AllowMouseOpenFail”
Option “BlankTime” “5”
Option “DontVTSwitch” “true”
Option “AIGLX” “false”
Option “GLX” “false”
Option “GLCore” “false”
EndSection

Section “InputDevice”
Identifier “keyboard”
Driver “kbd”
Option “CoreKeyboard”
Option “XkbRules” “xorg”
Option “XkbLayout” “us”
Option “XkbVariant” “”
EndSection

Section “InputDevice”
Identifier “mouse”
Driver “mouse”
Option “Device” “/dev/input/mice”
Option “Protocol” “IMPS/2”
Option “Emulate3Buttons” “yes”
Option “ZAxisMapping” “4 5”
Option “CorePointer”
EndSection

Section “Monitor”
Identifier “Monitor1”
VendorName “ASUS”
ModelName “eeePC P701”
Modeline “800×480” 29.58 800 816 896 992 480 481 484 497 -HSync +Vsync # 60 Hz
EndSection

Section “Device”
Identifier “Device1”
Driver “vesa”
EndSection

Section “Screen”
Identifier “Screen1”
Device “Device1”
Monitor “Monitor1”
DefaultDepth 24
SubSection “Display”
Depth 8
Virtual 1680 1680
EndSubSection
SubSection “Display”
Depth 15
Virtual 1680 1680
EndSubSection
SubSection “Display”
Depth 15
Virtual 1680 1680
EndSubSection
SubSection “Display”
Depth 16
Virtual 1680 1680
EndSubSection
SubSection “Display”
Depth 24
Virtual 800 600
EndSubSection
EndSection

CentOS 5.2 now support PMP SIL3124

It can’t be until CentOS 5.2. As there is bug to use VMServer 2.0 in Fedora 9 which support PMP SIL3124 with my CFI enclosure, I fall back to use the stable CentOS 5.2 which work perfect with VMServer 2.0.

I can have rock solid stable host running CentOS 5.2 which allow me to extend my storage with PMP SIL3124 linked up with CFI enclosure to build RAID5. Then install VM Server 2.0 to test different OS.